Welcome, Guest. Please Login or Register
  (UTC)
AvP Unknown
News:
Normal Topic AVP2 Launch Error: CGameClientShell::OnEngineInitialized (Read 1726 times)
Smarty96
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 5
Joined: Mar 22nd, 2021
Gender: Male
AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Mar 22nd, 2021 at 8:35pm
Print Post Print Post  
Hi Guys,

I hope someone on here can help with a workaround or has a solution for this, when I launch AVP2 I get the message in the title, followed by 'Couldn't initialize InterfaceMgr!'. Has anyone come across this before? I've reinstalled the both AVP2 and Primal Hunt, and Primal Hunt runs perfectly.

Thanks guys!
Smarty 96
  
Back to top
 
IP Logged
 
x-M-x
Administrator
*****
Offline


'Defiance'

Posts: 1373
Location: Lost~
Joined: Apr 20th, 2010
Gender: Male
Re: AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Reply #1 - Mar 22nd, 2021 at 8:49pm
Print Post Print Post  
Did you install master server patch after avp2 being installed?


https://avpunknown.com/avp2master (msp 2.4)

Comes with a lot of hotfixes.

  
Back to top
IP Logged
 
Smarty96
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 5
Joined: Mar 22nd, 2021
Gender: Male
Re: AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Reply #2 - Mar 23rd, 2021 at 1:34pm
Print Post Print Post  
Can't say I did, I'll do a clean install and install that patch before attempting to launch, thank you!
  
Back to top
 
IP Logged
 
Smarty96
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 5
Joined: Mar 22nd, 2021
Gender: Male
Re: AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Reply #3 - Mar 23rd, 2021 at 1:42pm
Print Post Print Post  
So AVP2 now works, going to install Primal Hunt and see if it remains fixed as it has worked before without Primal Hunt being installed.
  
Back to top
 
IP Logged
 
Smarty96
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 5
Joined: Mar 22nd, 2021
Gender: Male
Re: AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Reply #4 - Mar 23rd, 2021 at 1:51pm
Print Post Print Post  
Okay, here's where I'm up to:
Installed AVP2 and the MP/SP updates and the 1.0.9.6 update, as well as the master server patch, all went well and AVP2 launched fine and I was able to start a campaign game. I then installed Primal Hunt and I am able to play this without a problem, but now AVP2 doesn't launch, I just get the little black box that appears and disappears really quick but no actual game launch  Grin any thoughts other than to do ANOTHER clean install?

  
Back to top
 
IP Logged
 
Smarty96
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 5
Joined: Mar 22nd, 2021
Gender: Male
Re: AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Reply #5 - Mar 23rd, 2021 at 2:10pm
Print Post Print Post  
IT WORKS! Turns out it was because I was installing it to my SSD, works perfectly on my HDD, I'm overjoyed!
  
Back to top
 
IP Logged
 
x-M-x
Administrator
*****
Offline


'Defiance'

Posts: 1373
Location: Lost~
Joined: Apr 20th, 2010
Gender: Male
Re: AVP2 Launch Error: CGameClientShell::OnEngineInitialized
Reply #6 - Mar 23rd, 2021 at 3:14pm
Print Post Print Post  
Smarty96 wrote on Mar 23rd, 2021 at 2:10pm:
IT WORKS! Turns out it was because I was installing it to my SSD, works perfectly on my HDD, I'm overjoyed!



Well i doubt it was anything to do with HDD/SSD (As myself have a full SSD System) and face no issues.

But long as it works? then congratulations!  Wink


Hope to see you on the servers sometime.

Cheers
x-M-x
  
Back to top
IP Logged