Welcome, Guest. Please Login or Register
  (UTC)
AvP Unknown
News:
Hot Topic (More than 10 Replies) AvP2 Dedicated Server timer issue (Read 18805 times)
[FP]Frosty
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 2
Location: Gagetown, MI USA
Joined: May 1st, 2014
Gender: Male
AvP2 Dedicated Server timer issue
May 1st, 2014 at 3:50am
Print Post Print Post  
Hey guys!

We have decided to put the Frosty's Playhouse AvP2 servers back up.  This is the game that was the start of the Frosty's Playhouse Clan (aka {FP}) 10 years ago.   It just doesn't seem right not having the servers running after all of this time.  Besides, it was a great game back then, and there are several of us in the Clan that want to play again.

However, once I got the server running again, the 15 minute timer counts down in about 65 seconds.  I don't remember having this problem in the past, but I'm old and that was a long time ago.  Smiley

In setting up the server, I completed the following:
  •   Installed a fresh copy of AvP2
  •   Installed 1093 patch
  •   Installed 1096 patch
  •   Installed Sp1 patch
  •   Installed MP1 patch
  •   Installed Master Server Browser patch v1.5.4
  •   Installed Rommie's Mod v5.0
  •   Configured server files

I'm not sure if I am missing something or what, and I hope you can help.  I have had the server down, since it doesn't really work, but I will bring it up in case anyone wants to check out what it's doing firsthand.

SERVER INFO:
Frosty's Playhouse - No Track
198.0.118.85:27888

The server is configured as follows:
  •   Windows Server 2008 R2
  •   4 Quad-Core Intel Xeon 2.4GHz processors
  •   32 GB RAM
  •   Comcast Internet - 50/10

Any help you guys could provide would be greatly appreciated!

Thanks!
-Frosty



  
Back to top
IP Logged
 
x-M-x
Administrator
*****
Offline


'Defiance'

Posts: 1377
Location: Lost~
Joined: Apr 20th, 2010
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #1 - May 1st, 2014 at 5:12am
Print Post Print Post  
Hey Frosty,

--

Long time no see man... must of been years! glad you're still around!

---
----
--------

Anyway, as for your problem, well I've had this happen to me in the past! i cant really remember what was the cause but i was told it has something to do with X64 Systems? (which your system is)  Smiley

I'm sure the others will post here soon

We're here to help!

Wink

***EDIT***

Think i remember... try and 'Set Affinity' for the AvP2server.exe to 1 processor ?

« Last Edit: May 1st, 2014 at 7:13am by x-M-x »  
Back to top
IP Logged
 
[FP]Frosty
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 2
Location: Gagetown, MI USA
Joined: May 1st, 2014
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #2 - May 2nd, 2014 at 5:11am
Print Post Print Post  
Hey x-M-x!  It sure has been a long time.  Hopefully we can get in a game together soon.

I tried changing the Affinity setting from 255 (to use 8 of the 16 cores) down to 1.  Unfortunately, the problem continued. In the testing, I also noticed that it was just repeating the Stronghold map over and over.  After a little more testing and tweaking, I found the problem.

In the Customerez.txt file, I had a line that read 'Rez2=Maps'.  A total rookie mistake; I forgot the quotes around Maps.  I changed the line to 'Rez2="maps"' and the server works great!

Like we've both mentioned, it's been years since I've played AvP2 or run the servers.  Smiley

Thanks for the help and I look forward to playing with the community once again!

-Frosty

  
Back to top
IP Logged
 
x-M-x
Administrator
*****
Offline


'Defiance'

Posts: 1377
Location: Lost~
Joined: Apr 20th, 2010
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #3 - May 2nd, 2014 at 5:35am
Print Post Print Post  
Hey!

Glad it worked! and yes now i remmeber... that is soo rookie by us lol we're old dude!!!

I'll make a topic about this and sticky it in tech support so others know how to fix this!

And yes we'll play soon!!! i remember your servers! and if you're free stop by my server sometime you cant miss it!  Smiley

x-M-x
  
Back to top
IP Logged
 
Corax
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 29
Location: BC, Canada
Joined: Mar 17th, 2011
Gender: Female
Re: AvP2 Dedicated Server timer issue
Reply #4 - May 19th, 2014 at 2:37am
Print Post Print Post  
haha Mandy.  I pestered Frosty to get the old servers up again.  Looking forward to playing again yay!!! Smiley
  
Back to top
 
IP Logged
 
Grave
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 1
Joined: Aug 25th, 2014
Re: AvP2 Dedicated Server timer issue
Reply #5 - Aug 27th, 2014 at 2:26pm
Print Post Print Post  
Hi.

Can I ask what exactly do I need in the customrez.txt file so my dedicated server's game timer would run normally?

I only have:
[Rez]
Rez0="avp2p5.rez"
Rez1="lithserver.rez"

After I added Rez2="maps" the issue still remained.
  
Back to top
 
IP Logged
 
[f4]meatball
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 2
Joined: Jul 15th, 2010
Re: AvP2 Dedicated Server timer issue
Reply #6 - Nov 23rd, 2014 at 6:33pm
Print Post Print Post  
afaik this is caused by energy saving in modern computers. CPU frequency/speed is adjusted depending on current system load, and avp2 (very old game made before cpu power saving was installed in every computer) changes speed as well. To fix avp2 you need to adjust "power saving options" of your system to force CPU to work at constant speed.
  
Back to top
 
IP Logged
 
TBBC
Spawnkiller
*
Offline


AVP Rules!!!

Posts: 30
Joined: Feb 19th, 2013
Re: AvP2 Dedicated Server timer issue
Reply #7 - Nov 23rd, 2014 at 8:17pm
Print Post Print Post  
No this is caused by a bug in LithTech's internal timer. This is more obvious on some server mods that set their update rate higher than 100 ticks per second, but every server will deteriorate over time. In the past they remedied this by using a different clock for some multiplayer timers but under the hood nothing has changed. This is the same bug that makes players teleport back and forth on servers that have been running for a few days, which makes the game nearly unplayable.

It's relatively easy to fix if you know what to do but it requires a basic understanding of assembly language. We fixed this long ago but because of the "helpfulness" of some other community members, and you know who you are Tongue, we never bothered to release it. However, things have changed and we will probably release this fix in an upcoming update in the near future. For now I recommend restarting your server every two days.
  
Back to top
 
IP Logged
 
x-M-x
Administrator
*****
Offline


'Defiance'

Posts: 1377
Location: Lost~
Joined: Apr 20th, 2010
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #8 - Dec 9th, 2014 at 10:59pm
Print Post Print Post  
Or you could simply run avp2 servers on older hardware... lol crazy.

Looking forward to that Fix TBBC!
  
Back to top
IP Logged
 
Lucifer
Warriors
*****
Offline


Ego te absolvo Hell Rules!

Posts: 583
Location: Hell
Joined: Jun 24th, 2013
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #9 - Mar 1st, 2015 at 2:15pm
Print Post Print Post  
I thought it was a problem only for new windows but also on xp sp3 there is the same problem .
exist a fix?
« Last Edit: Mar 1st, 2015 at 2:21pm by Lucifer »  


"Are you the devil? Perhaps abuse your position. Or dominate and control others instead of dominating yourself. Or bring illusions and hide the truth. Recognize your demonic side if you want to succeed in transcending it. "
Back to top
 
IP Logged
 
[AvP2]Seal
Spawnkiller
*
Offline


When i speak.... Everyone
listens~

Posts: 26
Location: LV-8720
Joined: Apr 24th, 2010
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #10 - Mar 1st, 2015 at 2:21pm
Print Post Print Post  
Lucifer wrote on Mar 1st, 2015 at 2:15pm:
I thought it was a problem only for new windows but also on xp sp3 there is the same problem


If the hardware is old as x-M-x says... then it should be fine.
  


- Whoever wins... We lose (AvP)
Back to top
 
IP Logged
 
Lucifer
Warriors
*****
Offline


Ego te absolvo Hell Rules!

Posts: 583
Location: Hell
Joined: Jun 24th, 2013
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #11 - Mar 2nd, 2015 at 8:08am
Print Post Print Post  
no my hardware is new but
I wonder whether there might be an alternative for new hardware to force the cpu to a constant speed. I wonder why this problem does not present if you create a non-dedicated server?
« Last Edit: Mar 2nd, 2015 at 10:16am by Lucifer »  


"Are you the devil? Perhaps abuse your position. Or dominate and control others instead of dominating yourself. Or bring illusions and hide the truth. Recognize your demonic side if you want to succeed in transcending it. "
Back to top
 
IP Logged
 
x-M-x
Administrator
*****
Offline


'Defiance'

Posts: 1377
Location: Lost~
Joined: Apr 20th, 2010
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #12 - Mar 2nd, 2015 at 5:35pm
Print Post Print Post  
Lucifer wrote on Mar 2nd, 2015 at 8:08am:
no my hardware is new but
I wonder whether there might be an alternative for new hardware to force the cpu to a constant speed. I wonder why this problem does not present if you create a non-dedicated server?


Why not get a really old 'computer' via ebay or something set it up for avp2 servers?

That's what i would do!


  
Back to top
IP Logged
 
The_One
Spawnkiller
*
Offline


LITHFAQ Owner... good
times!

Posts: 3
Joined: Apr 5th, 2015
Gender: Male
Re: AvP2 Dedicated Server timer issue
Reply #13 - Jul 2nd, 2015 at 5:03am
Print Post Print Post  
A fix that should be added to the main loop of the server app...

Sleep(1);
  

- Original AvP2/Master Server Developer
Back to top
 
IP Logged